2018.09.12 | Linux | 1 条评论


由于netease-cloud-music_1.1.0_amd64_ubuntu.deb打包可能有问题,在Ubuntu 16.04/18.04版本中虽然可以安装,但是必须在命令行使用sudo netease-cloud-music才能启动,很麻烦。

所以一般我们使用netease-cloud-music_1.0.0_amd64_ubuntu.deb版本(下载地址)但是其依赖依旧有问题,其中一个依赖已经被系统替换了,所以我们必须在deb包的依赖环境里面删掉这个依赖,然后重新打包,这样就可以安装了。

具体解决办法如下:

修改依赖

1. 创建软件包目录

mkdir -p extract/DEBIAN

2. 用dpkg解压

dpkg-deb -x netease-cloud-music_1.0.0_amd64_ubuntu.deb extract/
dpkg-deb -e netease-cloud-music_1.0.0_amd64_ubuntu.deb extract/DEBIAN

3. 文本编辑器打开extract/DEBIAN/control,

gedit extract/DEBIAN/control

4. 找到Depends行,删除libqt5libqgtk2,删除libfontconfig1 (>= 2.11.94)中的(>= 2.11.94)

重新打包

1. 建立软件包生成目录

mkdir build

2. 重新打包

dpkg-deb -b extract/ build/

3. 安装新打包的网易云

sudo dpkg -i build/netease-cloud-music_1.0.0_amd64_ubuntu.deb

参考资料

版权声明

本作品由idealclover采用知识共享署名-相同方式共享 4.0 国际许可协议进行许可,转载请注明出处

标签: sudo, extract, 打包, dpkg-deb, 依赖, mkdir

0

只有一条评论 QAQ

  1. LingC
    LingC 回复

    关于这个我也写了一篇文章